Wikimásolattükör

Ez a pascal.chat wikijének tükre. A szerkesztés, az előzmények és a bejelentkezés ott érhető el.

Main menu/hu

Deutsch · English · Español · Français · Italiano · Magyar · Nederlands · Português · Shqip · Slovenčina · Suomi · Македонски · Русский · 中文(中国) · 中文(台灣) · 日本語

A főmenü

A fő menüsor a következő elemeket tartalmazza: Fájl Szerkesztés Keresés Nézet Projekt Futtatás Csomag Eszközök Környezet Ablak Súgó

Megszokott módon, a menüpontok kiválaszthatók az egérrel, vagy az Alt+F lenyomásával.

Fájl menü

Szerkesztés menü

Keresés menü

'''

Nézet menü

A különböző ablakok és panelek megjelenítését vezérelheted innen. Azok az ablakok, amelyek meg vannak nyitva, előtérbe hozhatók, illetve amelyek nem voltak megnyitva, innen megnyithatók.

Projekt menü

Futtatás menü

Fordítás folyamatban... Nem lefordított angol szöveg

One very important use of this sub-menu is to activate a terminal window in which conventional Pascal console input/output is displayed. If you are developing a console-mode Pascal program (ie one that doesn't use the Graphical User Interface with its forms, buttons and boxes) then you should check the box for "Use launching application". The first time you do this and try the Compile/Run sequence, you will probably get a rude message to say

text
"xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied".

If this happens, you need to change the permissions on the appropriate file (for example using chmod +x filename, or using the Windows utility for changing permissions); you might have to do this as root. After this, each time you launch you program, a console box will appear and all your text i/o (readln, writeln etc) will appear in it.

After your program has finished execution, a message "Press enter" appears on the screen. Thus any output your program generated will remain on the screen until you have had a chance to read it; after you press 'enter' the console window closes.

Note: as for the current version, there is no prepared console command for Windows users. Until the Lazarus team adressess that, the following line should work (on WinXP -- someone please update for other Windowses)

text
C:\Windows\system32\cmd.exe /C ${TargetCmdLine}

See the separate tutorial on Console Mode Pascal programming.

These last three options enable you to open (and maintain) a test project. Use File -> Open to open an .lpr file, pressing cancel on the next dialog to open this file as "normal source" file.

The Package sub-menu

The Tools sub-menu

Standard packages add the following menu items:

The Environment sub-menu

Most of these settings are auto generated and read only.

The Windows sub-menu

Contains a list of the currently opened files and the available windows such as Source Editor, Object Inspector and Project Inspector. Clicking on the name of one of the windows brings it to the foreground and gives it focus.

The Help sub-menu

At present this has three selections:

At present by default, if you place your Editor cursor over any keyword from the Free Pascal Components Library FCL, the RunTime Library RTL or the Lazarus Components Library LCL, and then press F1 you will be taken by your default browser to the appropriate definition on the website. Be aware that your browser may be located on another desktop on your machine (eg in Linux), and you may not see the information immediately; of course if you are not connected to the internet you cannot get this information.

There are alternative help options which gives the end-user off-line help. For example, if you have a copy of Kylix, you can reuse the help files supplied with it, inside Lazarus IDE. See the Adding Kylix Help page for details.

Eventually there will be a full on-line Help service, with information about Pascal syntax, the use of the IDE, how to use, modify or create Components, and hints on how to perform certain tasks. This part of the Documentation section (the thing you are currently reading) represents the beginning of the process. We need contributions from anyone who feels able to provide them: the WiKi is very easy to edit.


From the Free Pascal wiki, page "Main menu/hu", as it stood on 2021-12-08 after a change by Kupferstecher, out of the wiki's dump of 2024-05-26. Copyright stays with the author who wrote it, according to the old wiki's Licensing page. If you have concerns about this material, message the admin.

3. változat, utoljára módosította: WikiArchive, .