Kopia wikimirror

To jest mirror wiki z pascal.chat. Edycja, historia i logowanie są tam.

FPDoc Editor/pl

Deutsch · English · Français · Polski · Português · Русский · 日本語

Wprowadzenie

FPDoc jest narzędziem do tworzenia dokumentacji Free Pascal, które jest specjalnie zaprojektowane do tworzenia plików pomocy dla poszczególnych modułów kodu źródłowego Pascala. Więcej informacji o FPDoc znajdziesz tutaj: Podręcznik do narzędzia tworzenia dokumentacji dla Free Pascala.

Lazarus udostępnia wbudowaną przeglądarkę pomocy FPDoc z podpowiedziami oraz dwa edytory plików pomocy, z których możesz korzystać do tworzenia lub aktualizowania dokumentacji kodu źródłowego w formacie FPDoc. Jeśli chcesz od razu zobaczyć, czy jest poprawnie sformatowany, musisz zainstalować pakiet TurboPowerIProDsgn.lpk! Prosty edytor, zintegrowany z Lazarus IDE, nazywa się FPDoc Editor i jest opisany na tej stronie. Istnieje również bardziej kompletny i złożony edytor o nazwie LazDE.

LazDE jest większym bratem FPDoc Editor i jest edytorem dokumentacji Lazarusa. Jest to samodzielna aplikacja (nie jest integralną częścią IDE). Znajduje się w ścieżce lazarusa ($LazDir)/doceditor/lazde.lpi. Po skompilowaniu projektu lazde (przy użyciu Lazarusa) LazDE będzie działać poza środowiskiem IDE. Możesz dodać go do menu Narzędzia jako narzędzie zewnętrzne.

Korzystanie z edytora FPDoc

Aby użyć edytora FPDoc po prostu:

1. Otwórz edytor FPDoc. Znajdziesz go w menu Widok.

2. W edytorze kodu źródłowego Lazarusa przesuń kursor na jakiś element kodu. Zauważysz, że podpis edytora FPDoc zmienia się, pokazując wybrany element źródłowy wraz z nazwą pliku dokumentacji. W edytorze FPdoc możesz wybrać odpowiednią stronę, na której możesz edytować określony znacznik dokumentacji. Oczywiście możliwe jest również użycie edytora FPDoc tylko do przeglądania plików dokumentacji, bez ich zmiany.

3. Kliknij przycisk Utwórz element pomocy. Jeśli nie skonfigurowałeś jeszcze ścieżek wyszukiwania dla FPDoc, IDE zapyta Cię, gdzie powinny być przechowywane generowane przez nie pliki FPDoc. Dla każdego ze swoich projektów zwykle udostępniasz podkatalog 'docs'.

4. Napisz krótki opis.

5. Kliknij przycisk Zapisz po lewej stronie lub przejdź do następnego elementu (edytor automatycznie zapisuje opis, gdy od niego odejdziesz).

Edytowane wpisy FPDoc dla źródeł LCL i źródeł Lazarusa

Znajdują się w folderze ($LazDir)\docs\xml. Możesz dodać ten folder do ścieżek FPDoc w menu Narzędzia / Opcje / Środowisko / Edytor FPDoc

Edytowane wpisy FPDoc dla źródeł FPC, RTL i FCL

Wpisy FPDoc dla źródeł FPC można pobrać z svn:

bash
cd /home/{u??ytkwonik}/{tw??j_wyb??r}/
git clone https://gitlab.com/freepascal.org/fpc/documentation.git
lub z repozytorium lustrzanego na GitHub:
git clone https://github.com/fpc/FPCDocumentation.git fpcdocs

Warning: Pobieranie z serwera svn już nie działa (svn co <http://svn.freepascal.org/svn/fpcdocs/trunk> fpcdocs)

Dodaj ścieżkę /home/{użytkwonik}/{twój_wybór}/fpcdocs do Narzędzia / Opcje / Środowisko / Edytor FPDoc

Dobrym elementem do testowania FPDoc jest TComponent.Name.

Przyszłe plany

Lista rzeczy do zrobienia (todo) zawiera obecnie następujące elementy, w dowolnej kolejności:

Już zrobione


From the Free Pascal wiki, page "FPDoc Editor/pl", as it stood on 2022-06-01 after a change by Slawek, out of the wiki's dump of 2024-05-26. Copyright stays with the author who wrote it, according to the old wiki's Licensing page. If you have concerns about this material, message the admin.

Wersja 4, ostatnia zmiana: WikiArchive, .